Learn English – How to concisely handle words that don’t have an antonym

antonymsword-choice

I work in software for a living, and have had a problem recently with the language I use to describe software components. This profession increasingly reveals itself to need the skill to accurately and concisely describe something. My problem is thus: Often I create actors that do something, and other actors that undo something, but I cannot simply invert the words I describe the former with to describe the latter. I need words to name "the thing that undoes".

To use a recent example: the word "wrapper". A quick search in the internet reveals that wrapper is a word, and has a listing of synonyms… but there are no antonyms. Similarly, I tried enveloper and packer, expecting at least "unpacker" to be a word, alas it is not. I haven't done an exhaustive search, yet there seems to be a pattern of words of this form not having an opposite.

Ignoring the legality of the words and using "unwrapper" is a possibility, but spellcheck is going to complain. Maintaining exclusion rules also seems rather… tiresome.

I'd also like to avoid having to use too many words to describe things that undo something. I could have a pair such as "wrapper" and "wrappedcontentremover", but that is mighty inelegant.

For clarity's sake, I mean "one who wraps" and not "material used to coat".

Is there a way to handle this in a legal and concise way?

Best Answer

Ignoring the legality of the words and using "unwrapper" is a possibility

English is a changing language. Your goal is to communicate precisely with humans. Given that "unwrap" and "wrapper" are familiar words, no English reader will have trouble understanding what an "unwrapper" is, and is what I would use.

but spellcheck is going to complain

Our software should serve us, and not vice versa.

I need words to name "the thing that undoes".

Looking at this from the software architecture, if you find yourself needing to define a pair of names for each action, it seems like you're begging for a better abstraction. One option is to bundle the doing and undoing behavior into a single actor for each action. It's common for classes implementing the Command pattern to do that. If not that, maybe you can make a single "undoer" type that can generically undo any action.